The system requires that the variable $ve_code has a valid data.